aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-10 14:27:14 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-14 18:15:08 -0700
commitb47d8d5992da626f01620745d2a60d048734c4df (patch)
treedbb68e22932e920d2f90d6d1ea2543328a8b8be1 /CMakeLists.txt
parentf4f791ffbdd281af48aae610bf88ef5fd6ae2ac9 (diff)
downloadsubsurface-b47d8d5992da626f01620745d2a60d048734c4df.tar.gz
Some simple test for file parsing
With no V2 question shown - parsing fails when a V2 file is loaded - parsing succeeds when a V3 file is loaded - import of CSV file succeeds With V2 question shown - parsing succeeds when a V2 file is loaded Finally compare the output of reading in the various files with reference output included in the sources. My guess is that this test might be a bit fragile, but hey, it's a start. (reminder: the tests only get built when using cmake) Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b197bfc3e..c1d86caef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -152,6 +152,7 @@ SET(SUBSURFACE_CORE_LIB_SRCS
devicedetails.cpp
configuredivecomputer.cpp
configuredivecomputerthreads.cpp
+ divesitehelpers.cpp
)
#the interface, in C++
@@ -265,6 +266,9 @@ MACRO(test NAME FILE)
ENDMACRO()
ENABLE_TESTING()
+ADD_DEFINITIONS(-DSUBSURFACE_SOURCE="${CMAKE_SOURCE_DIR}")
+ADD_DEFINITIONS(-g)
test(TestUnitConversion testunitconversion.cpp)
test(TestProfile testprofile.cpp)
test(TestGpsCoords testgpscoords.cpp)
+test(TestParse testparse.cpp)