aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-04-07 16:13:27 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-07 16:27:39 -0700
commitc2bdc58fb8d9731fdbc3889017e8a7991da73ce9 (patch)
treedc20db7a4b2f9032f4b7d4ab8b74ed3bda7ae62f /CMakeLists.txt
parent6f935907053a6f2cc97b1fafed4a6896d40f6874 (diff)
downloadsubsurface-c2bdc58fb8d9731fdbc3889017e8a7991da73ce9.tar.gz
Make it compilant with the build script
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 74accf273..56da823f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,9 +39,13 @@ ELSE()
ENDIF()
FIND_PACKAGE(Libdivecomputer REQUIRED)
+INCLUDE_DIRECTORIES(${LIBDIVECOMPUTER_INCLUDE_DIR})
+
FIND_PACKAGE(Marble REQUIRED)
include_directories(${MARBLE_INCLUDE_DIR})
+SET(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} -lusb-1.0)
+
# handle out of tree build correctly
STRING(COMPARE EQUAL "${${PROJECT_NAME}_SOURCE_DIR}" "${${PROJECT_NAME}_BINARY_DIR}" insource)