aboutsummaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-08-04 12:02:29 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-08-12 07:36:10 -0700
commitb98ba9ba94cb4d7293daa80139c6bd7ecda882fe (patch)
tree4fe38fae4db60a777737cf7d9f738c7ac28565a4 /core/CMakeLists.txt
parent3c69c8299b88ab8f3ce9212e5d10d81f9f687702 (diff)
downloadsubsurface-b98ba9ba94cb4d7293daa80139c6bd7ecda882fe.tar.gz
core: create qPrefTechnicalDetails from SettingsObjectWrapper
Update set/get functions to follow common name scheme: - get function have same name as in struct diveComputer - set function have set_<name> - signal function have <name>_changed one class one .h/.cpp is the C++ idiom. Having load/sync of each variable in 1 functions (in contrast to the distributed way SettingsObjectWrapper handles it) secures the same storage name is used. Having the set/get/load/sync functions grouped together makes it easier to get an overview. REMARK: this commit only defines the class, it is not active in production Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index b5a51fc88..61fb09705 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -111,6 +111,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
settings/qPrefFacebook.cpp
settings/qPrefPrivate.cpp
settings/qPrefProxy.cpp
+ settings/qPrefTechnicalDetails.cpp
settings/qPrefUnit.cpp
settings/qPrefUpdateManager.cpp