aboutsummaryrefslogtreecommitdiffstats
path: root/core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jani@apache.org>2018-06-16 16:03:31 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-07-04 05:32:30 +0800
commitd02a03983d91da1d10aac5b0a5d84d15e94e9291 (patch)
tree15be085ead1635f40ce467ae8dec9aa5d4dc4eea /core/CMakeLists.txt
parent6c9c2168e1d685aa1a777097dbf2330621dcf963 (diff)
downloadsubsurface-d02a03983d91da1d10aac5b0a5d84d15e94e9291.tar.gz
core: add qPref.h_and qPrefprivate.h
add 2 header files and 1 cpp file (qPrefPrivate does not have an implementation) The rewrite/consoliadation of SettingsObjectWrapper, qmlmanager, qmlpref and planner needs a place to put common private parts (qPrefPrivate) and 1 common class (qPref). Signed-off-by: Jan Iversen <jani@apache.org>
Diffstat (limited to 'core/CMakeLists.txt')
-rw-r--r--core/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/core/CMakeLists.txt b/core/CMakeLists.txt
index de9f9edae..694108b1c 100644
--- a/core/CMakeLists.txt
+++ b/core/CMakeLists.txt
@@ -98,6 +98,9 @@ set(SUBSURFACE_CORE_LIB_SRCS
windowtitleupdate.cpp
worldmap-save.c
+ # classes to manage struct preferences for QWidget and QML
+ settings/qPref.cpp
+
#Subsurface Qt have the Subsurface structs QObjectified for easy access via QML.
subsurface-qt/DiveObjectHelper.cpp
subsurface-qt/CylinderObjectHelper.cpp