aboutsummaryrefslogtreecommitdiffstats
path: root/desktop-widgets/plugins/facebook/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-10-29 21:47:08 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-30 10:36:52 -0700
commit8dad3457ef1f412517c4d81f08ebd14680788ec3 (patch)
treefd98ffd89584e4fa7a295b0116e8594a94c92e07 /desktop-widgets/plugins/facebook/CMakeLists.txt
parent391172240ae00e9729ddb9db1b2cd50be3feb51b (diff)
downloadsubsurface-8dad3457ef1f412517c4d81f08ebd14680788ec3.tar.gz
Make the skeleton Facebook plugin and make sure it is loaded
Currently we need to copy manually the plugin dynamic library to the /plugins folder. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/plugins/facebook/CMakeLists.txt')
-rw-r--r--desktop-widgets/plugins/facebook/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/desktop-widgets/plugins/facebook/CMakeLists.txt b/desktop-widgets/plugins/facebook/CMakeLists.txt
index cccfec1f5..8628bd070 100644
--- a/desktop-widgets/plugins/facebook/CMakeLists.txt
+++ b/desktop-widgets/plugins/facebook/CMakeLists.txt
@@ -1,5 +1,6 @@
set(FACEBOOK_PLUGIN_SRCS facebook_integration.cpp)
-add_library(facebook_integration ${FACEBOOK_PLUGIN_SRCS})
+add_library(facebook_integration SHARED ${FACEBOOK_PLUGIN_SRCS})
-target_link_libraries(facebook_integration subsurface_core ${QT_LIBRARIES})
+target_link_libraries(facebook_integration subsurface_corelib ${QT_LIBRARIES})
+add_dependencies(facebook_integration subsurface_corelib) \ No newline at end of file