aboutsummaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar willemferguson <willemferguson@zoology.up.ac.za>2019-12-07 20:27:25 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-12-25 02:57:42 +0900
commit3e853e37a5b0b9509fb92b1ddb3031f117578fb9 (patch)
tree35281a57f8ca70611c78a85ef3dbfa459d9efacb /desktop-widgets/preferences/CMakeLists.txt
parentc121afc96c0135ada550de4504153434fa83feb4 (diff)
downloadsubsurface-3e853e37a5b0b9509fb92b1ddb3031f117578fb9.tar.gz
Preferences UI: create new equipment tab
Remove the "Show unused cylinders" checkbox (Profile tab) and the "Set default cylinder" qTextEdit box (General tab) and put them in a separate and new Equipment tab. This sounds like a simple task but, as can be seen from the files changed, was actually a complex matter. Adapt the existing test programs (General and TechDetails) for creating a test program that tests parts of the Equipment tab. Signed-off-by: willemferguson <willemferguson@zoology.up.ac.za> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
index 6f7f657cb..af6071934 100644
--- a/desktop-widgets/preferences/CMakeLists.txt
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -12,6 +12,7 @@ set(SUBSURFACE_PREFERENCES_UI
preferences_units.ui
preferences_georeference.ui
preferences_language.ui
+ preferences_equipment.ui
)
qt5_wrap_ui(SUBSURFACE_PREFERENCES_UI_HDRS ${SUBSURFACE_PREFERENCES_UI})
@@ -23,6 +24,8 @@ set(SUBSURFACE_PREFERENCES_LIB_SRCS
abstractpreferenceswidget.h
preferences_defaults.cpp
preferences_defaults.h
+ preferences_equipment.cpp
+ preferences_equipment.h
preferences_georeference.cpp
preferences_georeference.h
preferences_graph.cpp