aboutsummaryrefslogtreecommitdiffstats
path: root/desktop-widgets/preferences/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-11-09 18:57:47 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-09 18:00:56 -0800
commitc71df5baa5fb161a7d873912d27773ab8b2e4212 (patch)
tree878fd4e5dd8533844f360c16a01ab353a14c551a /desktop-widgets/preferences/CMakeLists.txt
parente1d43ade275313f643b27b2c30fd372f6c6ccd02 (diff)
downloadsubsurface-c71df5baa5fb161a7d873912d27773ab8b2e4212.tar.gz
Don't rely on CMAKE_AUTOUIC
Some old CMakes that we use had problems with it, change to use the qt5_wrap_ui macro that's bundled with Qt. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'desktop-widgets/preferences/CMakeLists.txt')
-rw-r--r--desktop-widgets/preferences/CMakeLists.txt10
1 files changed, 9 insertions, 1 deletions
diff --git a/desktop-widgets/preferences/CMakeLists.txt b/desktop-widgets/preferences/CMakeLists.txt
index 4e506ed73..7a934a2a5 100644
--- a/desktop-widgets/preferences/CMakeLists.txt
+++ b/desktop-widgets/preferences/CMakeLists.txt
@@ -4,7 +4,15 @@ include_directories(.
${CMAKE_BINARY_DIR}
)
-file(GLOB SUBSURFACE_PREFERENCES_UI *.ui)
+set(SUBSURFACE_PREFERENCES_UI
+ preferences_defaults.ui
+ preferences_graph.ui
+ preferences_network.ui
+ preferences_units.ui
+ prefs_georeference.ui
+ prefs_language.ui
+)
+
qt5_wrap_ui(SUBSURFACE_PREFERENCES_UI_HDRS ${SUBSURFACE_PREFERENCES_UI})
source_group("Subsurface Interface Files" FILES ${SUBSURFACE_PREFERENCES_UI})