aboutsummaryrefslogtreecommitdiffstats
path: root/packaging/ubuntu/debian
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2014-12-15 12:08:05 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-12-15 12:09:38 -0800
commit6da5775c05c86db6b7bfee5b9369e4853cdd45c3 (patch)
treeec3dbe79961b80da66884a207ccf9f9895e6821c /packaging/ubuntu/debian
parent5e9c491f194bc1a188dcc80ce322d0d588f588b0 (diff)
downloadsubsurface-6da5775c05c86db6b7bfee5b9369e4853cdd45c3.tar.gz
Ubuntu packaging: more tweaks
* only build a static libdivecomputer * only build the libgit2 library, not the executable * don't echo all the symlinks when fake-installing libmarblewidget Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'packaging/ubuntu/debian')
-rwxr-xr-xpackaging/ubuntu/debian/rules8
1 files changed, 5 insertions, 3 deletions
diff --git a/packaging/ubuntu/debian/rules b/packaging/ubuntu/debian/rules
index a4c51d912..61799c31b 100755
--- a/packaging/ubuntu/debian/rules
+++ b/packaging/ubuntu/debian/rules
@@ -18,8 +18,10 @@ override_dh_auto_clean:
rm -f Makefile
override_dh_auto_configure:
- (cd libdivecomputer ; autoreconf --install ; ./configure ; make -j8 )
- (mkdir libgit2/build ; cd libgit2/build ; cmake -DBUILD_SHARED_LIBS=OFF .. ; sed -i 's/.so$/.a/' CMakeCache.txt ; make -j8 )
+ (cd libdivecomputer ; autoreconf --install ; ./configure --disable-shared ; make -j8 )
+ (mkdir libgit2/build ; cd libgit2/build ; \
+ cmake -DBUILD_SHARED_LIBS=OFF -DBUILD_CLAR=OFF -DBUILD_EXAMPLES=OFF .. ; \
+ sed -i 's/.so$/.a/' CMakeCache.txt ; make -j8 )
(mkdir marble-build ; cd marble-build ; \
cmake -DQTONLY=ON -DQT5BUILD=ON \
-DBUILD_MARBLE_APPS=OFF -DBUILD_MARBLE_EXAMPLES=OFF \
@@ -27,7 +29,7 @@ override_dh_auto_configure:
-DBUILD_TESTING=OFF -DWITH_DESIGNER_PLUGIN=OFF \
-DBUILD_WITH_DBUS=OFF ../marble-source ; \
make -j8 ; \
- mkdir include ; cd include ; for i in `find ../../marble-source -name \*.h` ; do ln -s $$i . ; echo ln -s $$i . ; done ; \
+ mkdir include ; cd include ; for i in `find ../../marble-source -name \*.h` ; do ln -s $$i . ; done ; \
ln -s . marble )
qmake LIBDCDEVEL=./libdivecomputer LIBGIT2DEVEL=./libgit2 LIBGIT2STATIC=1 LIBMARBLEDEVEL=./marble-build SPECIAL_MARBLE_PREFIX=1 subsurface.pro