aboutsummaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Doug Junkins <junkins@foghead.com>2019-05-04 20:51:16 -0700
committerGravatar bstoeger <32835590+bstoeger@users.noreply.github.com>2019-05-06 10:48:44 +0200
commit00ec824129ea2662ace5a4077ba9bc865ecc70ff (patch)
treec722c55a48a6c226e879e3f2e915adb6fd3b13d6 /qt-models/CMakeLists.txt
parent98b3a326bd952c616843694821a48e0c029db699 (diff)
downloadsubsurface-00ec824129ea2662ace5a4077ba9bc865ecc70ff.tar.gz
Create DivesiteImportDialog to select sites to import
Creates the dialog box to select which sites to import from the file selected in mainwindow.cpp. The DivesiteImportModel is created as a table to display and select which sites are to be imported. Once the sites are selected, the Command::importDiveSites command is called to add the sites to the core dive site table with undo/redo functions. Signed-off-by: Doug Junkins <junkins@foghead.com>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 449b450e7..34d7ad783 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -29,6 +29,8 @@ set(SUBSURFACE_DESKTOP_MODELS_LIB_SRCS
divepicturemodel.h
diveplannermodel.cpp
diveplannermodel.h
+ divesiteimportmodel.cpp
+ divesiteimportmodel.h
divetripmodel.cpp
divetripmodel.h
filtermodels.cpp