aboutsummaryrefslogtreecommitdiffstats
path: root/qt-models/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Berthold Stoeger <bstoeger@mail.tuwien.ac.at>2020-05-15 17:05:34 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-09-29 16:13:03 -0700
commitaf9d379a4147b01ea599c86e0ff001cace926c1c (patch)
tree09fc7cb69d0f186a8575eb4efabd9eb19240ec19 /qt-models/CMakeLists.txt
parent634152ae43f37a62a67de5a5d5fc4e6b02829ce0 (diff)
downloadsubsurface-af9d379a4147b01ea599c86e0ff001cace926c1c.tar.gz
filter: add filter constraint model
Add a model that keeps track of a list of filter constraint and makes them accessible from Qt. Sadly, this is mostly repetitive boiler-plate code, but this is due to Qt's model/view-API, which is a perfect example of how *not* to design a reasonable modern API. Signed-off-by: Berthold Stoeger <bstoeger@mail.tuwien.ac.at>
Diffstat (limited to 'qt-models/CMakeLists.txt')
-rw-r--r--qt-models/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/qt-models/CMakeLists.txt b/qt-models/CMakeLists.txt
index 8d88e0712..280abbd41 100644
--- a/qt-models/CMakeLists.txt
+++ b/qt-models/CMakeLists.txt
@@ -19,6 +19,8 @@ set(SUBSURFACE_GENERIC_MODELS_LIB_SRCS
diveplotdatamodel.h
divetripmodel.cpp
divetripmodel.h
+ filterconstraintmodel.cpp
+ filterconstraintmodel.h
maplocationmodel.cpp
maplocationmodel.h
models.cpp