aboutsummaryrefslogtreecommitdiffstats
path: root/subsurface-core/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Sebastian Kügler <sebas@kde.org>2015-11-07 01:51:31 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-07 09:00:22 -0800
commit82f10380c9072638c00b5156038e0af6b28d2d5a (patch)
treeda539eb94b5f342ea853bf6af82359ecd1c3a24f /subsurface-core/CMakeLists.txt
parent10b68dad9625c5127e0d12614a73db2bfa950c7d (diff)
downloadsubsurface-82f10380c9072638c00b5156038e0af6b28d2d5a.tar.gz
Recognize Android as CMAKE_SYSTEM_NAME
This fixes the build for me against Qt 5.5. It seems Android is not Linux anymore, but uses its own CMAKE_SYSTEM_NAME now, so in this case we also want to compile android.cpp. This change should be rather safe, since it catches a condition that was not previously handled. Signed-off-by: Sebastian Kügler <sebas@kde.org> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'subsurface-core/CMakeLists.txt')
-rw-r--r--subsurface-core/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/subsurface-core/CMakeLists.txt b/subsurface-core/CMakeLists.txt
index bd4950767..b05dbe003 100644
--- a/subsurface-core/CMakeLists.txt
+++ b/subsurface-core/CMakeLists.txt
@@ -6,6 +6,8 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
else()
set(PLATFORM_SRC linux.c)
endif()
+elseif(CMAKE_SYSTEM_NAME STREQUAL "Android")
+ set(PLATFORM_SRC android.cpp)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(PLATFORM_SRC macos.c)
elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")