aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tcanabrava@kde.org>2016-04-05 14:22:00 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2016-04-05 12:32:36 -0700
commit21e8b1e363fcb46798aec49b623cfd2b29c286a3 (patch)
tree531c1c2318fb5cbe8139dfb0c723a0c190567e40 /tests/CMakeLists.txt
parent6d6ba8b54aad2ebcd7fc4259f6c9976022362ee5 (diff)
downloadsubsurface-21e8b1e363fcb46798aec49b623cfd2b29c286a3.tar.gz
Fix compilation with the new folder architecture
A few more fixes for things that broke in commit 7be962bfc287 ("Move subsurface-core to core and qt-mobile to mobile-widgets"). [Dirk Hohndel: slightly edited and overlap with Linus' patch removed] Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index a31e2c6f8..d516bb686 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,7 +1,11 @@
# QTest based tests
+qt5_add_resources(SUBSURFACE_TEST_RESOURCES ../subsurface.qrc)
+
+add_library(RESOURCE_LIBRARY STATIC ${SUBSURFACE_TEST_RESOURCES})
+
macro(TEST NAME FILE)
- add_executable(${NAME} ${FILE} ${SUBSURFACE_RESOURCES} )
- target_link_libraries(${NAME} subsurface_corelib ${QT_TEST_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} )
+ add_executable(${NAME} ${FILE} )
+ target_link_libraries(${NAME} subsurface_corelib RESOURCE_LIBRARY ${QT_TEST_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} )
add_test(NAME ${NAME} COMMAND $<TARGET_FILE:${NAME}>)
endmacro()