aboutsummaryrefslogtreecommitdiffstats
path: root/map-widget/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'map-widget/CMakeLists.txt')
-rw-r--r--map-widget/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/map-widget/CMakeLists.txt b/map-widget/CMakeLists.txt
new file mode 100644
index 000000000..4f1b5dc33
--- /dev/null
+++ b/map-widget/CMakeLists.txt
@@ -0,0 +1,8 @@
+# map widget to show locations
+
+# library used by mobile build
+set(SUBSURFACE_MAPWIDGET_SRCS
+ qmlmapwidgethelper.cpp
+)
+add_library(subsurface_mapwidget STATIC ${SUBSURFACE_MAPWIDGET_SRCS})
+target_link_libraries(subsurface_mapwidget ${QT_LIBRARIES})