aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Miika Turkia <miika.turkia@gmail.com>2015-11-08 20:08:41 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-10 09:10:04 -0800
commit77d7e773b913378486399d292cc21c4329387578 (patch)
tree170e826320e6906da4595a0a956a810e25cdb97b /CMakeLists.txt
parent003ddc6b52eb2dce06abc95a7c96f90bc40ec6be (diff)
downloadsubsurface-77d7e773b913378486399d292cc21c4329387578.tar.gz
Enable BT compilation earlier
Commit ba55c603953bb530de2fe97fa46098d8c87e6aa5 broke Bluetooth support for me. This patch moves the setting of BT_SUPPORT earlier, re-enabling BT download option on the download dialog. Signed-off-by: Miika Turkia <miika.turkia@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4bdbb741..c587177d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,6 +221,10 @@ if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
endif()
+if(BTSUPPORT)
+ add_definitions(-DBT_SUPPORT)
+endif()
+
# Generate the ssrf-config.h every 'make'
file(WRITE ${CMAKE_BINARY_DIR}/version.h.in
"#define VERSION_STRING \"@VERSION_STRING@\"
@@ -328,10 +332,6 @@ if(FBSUPPORT)
add_definitions(-DFBSUPPORT)
endif()
-if(BTSUPPORT)
- add_definitions(-DBT_SUPPORT)
-endif()
-
# add pthread to the end of the library list on Linux
# this is only needed on Ubuntu (why do these idiots break everything?)