aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4bdbb741..c587177d5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -221,6 +221,10 @@ if (BTSUPPORT AND "${Qt5Core_VERSION_STRING}" STRLESS "5.4.0")
list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
endif()
+if(BTSUPPORT)
+ add_definitions(-DBT_SUPPORT)
+endif()
+
# Generate the ssrf-config.h every 'make'
file(WRITE ${CMAKE_BINARY_DIR}/version.h.in
"#define VERSION_STRING \"@VERSION_STRING@\"
@@ -328,10 +332,6 @@ if(FBSUPPORT)
add_definitions(-DFBSUPPORT)
endif()
-if(BTSUPPORT)
- add_definitions(-DBT_SUPPORT)
-endif()
-
# add pthread to the end of the library list on Linux
# this is only needed on Ubuntu (why do these idiots break everything?)