aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Robert C. Helling <helling@atdotde.de>2020-11-15 22:12:21 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-12-03 13:26:55 -0800
commitb39e77071e79b31996151434970e1baa5249c0a4 (patch)
treead14301d93edcb4598f4a6ef3fd707aa7c88f58e /CMakeLists.txt
parent31f0741ecc0013cd361683e7fad9bf2c8c166a13 (diff)
downloadsubsurface-b39e77071e79b31996151434970e1baa5249c0a4.tar.gz
downloader: small improvements
Provide supported dive computer list on the command line and actually call the cli download. Still not functional. Signed-off-by: Robert C. Helling <helling@atdotde.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18428778f..c1116f0ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -200,7 +200,11 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
message(STATUS "Building Subsurface-mobile requires BT support")
set(BTSUPPORT ON)
elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DownloaderExecutable")
- set(SUBSURFACE_TARGET subsurface-downloader)
+ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ set(SUBSURFACE_TARGET Subsurface-downloader)
+ else()
+ set(SUBSURFACE_TARGET subsurface-downloader)
+ endif()
set(BTSUPPORT ON)
add_definitions(-DSUBSURFACE_DOWNLOADER)
message(STATUS "building the embedded Subsurface-downloader app")