aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 18428778f..c1116f0ce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -200,7 +200,11 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
message(STATUS "Building Subsurface-mobile requires BT support")
set(BTSUPPORT ON)
elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DownloaderExecutable")
- set(SUBSURFACE_TARGET subsurface-downloader)
+ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
+ set(SUBSURFACE_TARGET Subsurface-downloader)
+ else()
+ set(SUBSURFACE_TARGET subsurface-downloader)
+ endif()
set(BTSUPPORT ON)
add_definitions(-DSUBSURFACE_DOWNLOADER)
message(STATUS "building the embedded Subsurface-downloader app")